Performance Degradation.
Incident Report for SendHub
Resolved
All systems operational.
Posted over 2 years ago. Feb 10, 2015 - 11:26 PST
Investigating
We're investigating an elevated number of gateway timeout issues.
Posted over 2 years ago. Feb 10, 2015 - 10:54 PST