Service Disruption
Incident Report for SendHub
Resolved
This incident has been resolved.
Posted about 2 years ago. Jul 04, 2015 - 12:00 PDT
Monitoring
Systems have quickly returned to normal. We've continued looking for the root cause. Will continue to monitor over the next hour. Next update before 6pm pacific.
Posted about 2 years ago. Jul 03, 2015 - 17:10 PDT
Investigating
We're looking into an issue. More info before 5:20 pm Pacific.
Posted about 2 years ago. Jul 03, 2015 - 17:05 PDT